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Critérios de Avaliagao

1. Avaliagdes:
B1 - peso 4- 12 bimestre:
* 10 pontos (avalia¢do prevista para 28/03/2017).

B2 - peso 6 — 22 bimestre:

* 3 pontos (laboratérios)

* 7 pontos (Projetos com apresentacées em 06/06/2017 e
13/06/2017).

SUB - 1 projeto diferenciado (Substitui a menor nota):
* 10 pontos (Apresentacdo prevista para 20/06/2017).

***Datas de acordo com calendario académico!!!
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Objetivo: Utilizar o display de 7 segmentos do PLD para uma simples
contagem de 0 a 9 utilizando um decodificador 7448.

DISPLAY DE 7 SEGMENTOS
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Objetivo: Utilizar o display de 7 segmentos do PLD para uma simples
contagem de 0 a 9 utilizando um decodificador 7448.

O display de sete segmentos, é formado por sete leds, dispostos em
forma de oito. Quando se necessita de acenderonumero “0”, ligam-se os
leds correspondentes ao digito “0”, por exemplo, os segmentos a, b, ¢, d,

e f
C
n
g fmab . —
IIIII LR RERERERE NI o
o|l1|1|ofo|ojo| F
ab 1|1|ofa]|1|o]|1]| 2
f
o 1|1]a|1]|o]o]|a| 3
011001-1“
e c 1|04 |10 g5
d I CIERERERERE
HERR L8 G G VY0 5
ed§ cpto  AERERERERERE 8
o ala1|ofola 4| G
m I(
> kroton

A
Aula 8

Um dispositivo electréonico muito usado com os displays de 7 segmentos é o
descodificador BCD-7segmentos. O descodificadortem a fungéo de
interpretarum codigo (BCD) e gerar os sinais para ligar o digito
correspondente a este cédigo no display de 7 segmentos.

Porexemplo:
Entrada do descodificadorem BCD (Decimal Codificado em Binario)— 0000
Saida do descodificador para o display de 7 segmentos -0111111-gfedch

a
0
0 _ 1 Saidado

Entrada do 0 Descodificador 1 descodificador para

descodificador BCD - 7segmentos 1 4 display de 7
1

(0 em BCD) 0 1
1

segmentos (digito 0) I—I

Note que a saida do descodificador corresponde aligar os segmentos do
digito “0" de um display do tipo catodo comum.

Os descodificadores comerciais disponiveis séo: 7447 (&nodo comum)e
7448 (catodo comum).
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Descodificador BCD —7 segmentos. entrada
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Passo a passo
Iniciar um Novo Projeto
Para comecar a trabalhar em um projeto novo, primeiro temos que definir um
escopo para este projeto. O “software” Quartus Il facilita esta tarefa
fornecendo suporte na forma de um Assistente (“Wizard”). A criagdo de
um Novo Projeto segue as etapas detalhadas a seguir.
a) Selecionar File > New Project Wizard para iniciar o Assistente de Novo
Projeto o qual direciona a criagdo e configurages preliminares de um Novo
Projeto.
b) Na janela “New Project Wizard: Introduction” , clicar em Next.
: kroton
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Janela “New Project Wizard: Add Files”. O Assistente de Novo Projeto
permite incluir arquivos pré-existentes (se houver) no Projeto.

Mew Projoct Wizarel: Add Filas [paga 2 of 51- [S=)

Sieleat the desion flze you veent toindluds in e poject. Chok.Add Al 10 534 2 desin fles in b
et dimckons o the progect, Mola: you can akeeys add desgn ik o ke proge Ble

e name: [ L=
Tl rame [Tipe [lvery [Omagnectryisy [HOLwemaon  added
e

he piath names of wzrize Llger Livaries

= Back I HNet = Firesh Caosla
— 9 kroton

A
Aula 8

Na janela “New Project Wizard: Family & Device Settings”:

f.1) Especificar o tipo de dispositivo no qual o circuito projetado sera
implementado.

No campo “Device Family — Family:”, escolher Ciclone IVE como Familia do
dispositivo de destino.

f.2) Pode-se deixar o “software” Quartus Il selecionar um dispositivo especifico
na familia, ou podemos escolher o dispositivo explicitamente. Utilizaremos esta
ultima abordagem

No campo “Target device” escolher a opgao “Specific device selected in
‘Available devices’ list”.

f.3) No campo “Available devices” aparece uma lista de dispositivos
disponiveis, escolher o dispositivo denominado ﬂque éum
PLD utilizado na Placa Didatica de Desenvolvimer

o kroton
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Family & Device Settings [page 3 of 5]

—_— e - —

&4 New Project Wizard

Select the family and device you want to target for compilation.
You can install additional device support with the Install Devices command on the Tools menu.

To determine the version of the Quartus II software in which your target device is supported, refir to the Device Support List webpage.

Device family Show in Availzble devices' list

Family: [Cydone IVE =] Package: [any )

Devices: [All *|  Pincount: [any ~|

R ey 2
Name fiter:

Auto device selected by the Fitter
how advanced devices

Spedfic device selected in "Available devices' list

Other: nfa
Available devices:

Name Core Voltage LEs User I/0s Memory Bits Embedded multiplier 9-bit elements PLL ~
EP4CE7SF2317 12v 75408 293 2810880 400 4
EP4CE7SF2318L 1.0V 75408 293 2810880 400 4
EP4CE7SF29C6 e 75408 427 2310880 400 4
£P 4CE7SF25C 2310850 oo [+ ]
EP4CE7SF29CE L2v 75408 427 2810880 400 4
EP4CE7SF29CEL 1.0V 75408 427 2810880 400 4
EP4CE7SF29CAL 1.0V 75408 427 2810880 400 4 o
EP4CE7SF2917 12v 75408 427 2810880 400 4
EP4CE7SF2918L 1.0V 75408 427 2810880 400 4 2
« m r

<Back | [ MNextz |[ Fmsh | [ cancl |[ Hep |
H kroton
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€4 New Project Wizard — S— .. T Y =
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Summary [page 5 of 5]
Vihen you ik Finish, the project il be created with the folloning settings:
Project drectory: Cripiteral14.0
Projectname: aulal
Topevel desion entity: aulal
Number of fies added: 0
Number of user libraries added: 0
Device assignments:

Famiy name: Cydone VE

Device: EP4CE7SF2CT
EDA tools:

Design entry/synihesis <None> (<None>)

Smulation: ModelSim-Altera (VHDL)

Timing analysis: 0
Operating conditions:

VCCINT voltage: 1

Juncton temperature range: 085 C

[ <Back vext> | [_Foeh | [ Concel ][ rep |
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€ Quartus 11 64-5it - C/altera/140/aulel -aulal W W

File  Edit
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View Project Assignments Processing Tools Window Help )

|Project Navigator 38 x
Entity
/A Cydlone IV E: EPACE75F29CT
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> vierarchy | ElFes | ve 4|p |

[Tasks 2ax|
Flow: [ ~ | [customize... |
Task

4 Compile Design
b B Analysis & Synthesis

> B Fitter (Place &Route)
i %

A

QUARTUS® Il SOFTWARE v13.1:
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Download Free 30-Da
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Para descrever o circuito no formato de Captura de Esquematico deve-se usar o Editor
Gréfico do Quartus IL conforme as etapas detalhadas a seguir.

a)  Selecionar File > New para obter a janela da Figuwra 14. Escolher “Block Diagram /
Schematic File” e clicar em OK. Isso abre a janela do Editor Grafico (Figurals).
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b) O primeiro passo ¢ especificar um nome para o arquivo que serd criado. Sclecionar File
> Save as ... que abre a caixa de didlogo mostrada na Figura 16.
b.1) No campo “tipo:™ a op¢do Block Diagram/Schematic File (*. bdf) deve estar
selecionada.
b.2) O campo “name:” deve conter o nome do arquive. o mesmo nome dado ao
arquivo que foi especificado quando o projeto foi eriado.
b.3) A opgio “Add file to current Project™ deve estar selecionada.
b.4) Clicar em “Salvar’. o que armazena o arquivo mno diretério
C:lAlunos|dula_02\Nome_122100010 ¢ leva a janecla do Editor Grafico exibida
na Figura 17.
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O Editor Gréfico oferece uma série de bibliotecas que incluem elementos
de circuito que podem ser importados para um esquematico. Dé um duplo
cligue no espag¢o em branco na janela do Editor Gréfico, ou clique no
icone na barra de ferramentas que se parece com uma porta AND .

L

Va em “libraries”, em seguida, expandir a biblioteca “primitives”,
seguido de expansdo da biblioteca “logic” que compreende as portas
légicas. Selecione “and2”, que é uma Porta E de duas entradas, e clique
em OK. Agora, o simbolo da Porta E aparecera na janela do Editor
Grafico. Usando o mouse, mova o simbolo para um local conveniente e
cliqgue para coloca-lo la. Importar a segunda

18 kroton
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No PLD construir um conversor 7448 com as saidas para o display de 7
segmentos. New- Block Diagram- C:/ Altera — Others- 7448

Utilizar 4 chaves! Chama-las de Entl, Ent2, Ent3 e Ent4.

02/05/2017
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No PLD construir um conversor 7448 com as saidas para o display de 7
segmentos.

A
Aula 8

No PLD construir um conversor 7448 com as saidas para o display de 7
segmentos.

Apos isso, compile e comece a
conectar as entradas e saidas.

Utilizar as chaves SW0 — SW1-
SW2- SW3

E o 1° display.

Consultar a partir da pagina 36
do manual.

K

|,
22 kroton
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Compilar o Circuito Projetado

O arquivo do diagrama esquematico descrito — Luzes_de_Alerta.bdf, sera
processado por vérias ferramentas do Quartus Il que irdo analisar o arquivo,
sintetizar o circuito, e gerar uma implementacéo deste circuito para o chip de
destino. Estas ferramentas sao controladas pelo programa aplicativo chamado

Compilador.

Para executar o Compilador selecionar Processing > Start Compilation, ou
clicar no icone da barra de ferramentas horizontal.

-

A medida que a compilacéo passa pelos varios estagios, seu progresso
é relatado em uma janela no lado esquerdo da tela do Quartus Il (janela
“Tasks”). O sucesso (ou insucesso) do processo de compilagdo é

indicado em uma caixa de dialogo,

A
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Aparece status na
janela Tasks!!
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Atribuicéo de Pinos do PLD

Assignments > Pin Planner
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Atribuicdo de Pinos do PLD
Assignments > Pin Planner

Pag. 38 do Manual

— L =
§ Pin Planner - ClUsersCristana/Deskiop/Tesie/oulel - sl M g a p ===
=) = ®
5 Soe 8% Tap Vi - Wre Bend
Named: . Cyotre V€ EPACEN 20T
5| cnengom>> |
:
o
| B '
9 (et 98 x
i r
=
@u‘
%
3
| i1
]
@)

RIEY o =
o Locaten 10wk WEFGap  Fterloctn 10 Stnderd -
¥ PINFL 2.5V (defaut)

W= PO 25 (Gefa)
P04 25V (Gefout) |&
= e 25V (o)
PNLS 25 (efast)
P s 2.5V (defait)
03 25V (@efait) ~

(Sem som)]

Ha Transigio: Ripida

Jos

Figure 4-10 Connections between the 7-segment display HEX0 and Cyclone IV E FPGA

Table 4-4 Pin Assignments for 7-segment Displays

26
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Signal Name FPGA Pin No. Description I/O Standard

HEXO0[0] PIN_G18 Seven Segment Digit 0[0] 2.5V

HEXO0[1] PIN_F22 Seven Segment Digit 0[1] 2.5V

HEXO0[2] PIN_E17 Seven Segment Digit 0[2] 2.5V

/ANO[S RYA\

HEXO0[3] PIN_L26 Seven Segment Digit 0[3] Depending on JP7
HEXO0[4] PIN_L25 Seven Segment Digit 0[4] Depending on JP7
HEXO0[5] PIN_J22 Seven Segment Digit 0[5] Depending on JP7
HEXO0[6] PIN_H22 Seven Segment Digit 0[6] Depending on JP7
HEX1[0] PIN_M24 Seven Segment Digit 1[0] Depending on JP7
HEX1[1] PIN_Y22 Seven Segment Digit 1[1] Depending on JP7
HEX1[2] PIN_W21 Seven Segment Digit 1[2] Depending on JP7
HEX1[3] PIN_W22 Seven Segment Digit 1[3] Depending on JP7
HEX1[4] PIN_W25 Seven Segment Digit 1[4] Depending on JP7
HEX1[5] PIN_U23 Seven Segment Digit 1[5] Depending on JP7
HEX1[6] PIN_U24 Seven Segment Digit 1[6] Depending on JP7
HEX2[0] PIN_AA25 Seven Segment Digit 2[0] Depending on JP7
HEX2[1] PIN_AA26 Seven Segment Digit 2[1] Depending on JP7

27 kroton®
Atribuicdo de Pinos do PLD
Assignments > Assignment Editor

i - i A — , R |

Processing  Tools Window Help 5

Ty o N
[auiat ¥V D e OO0 RO B A 0@
| [ g compiation Report-auat [ | 7 aulatbdf 0| @ sssgmentedir () |
<<new>> v [V]Filter on node names: * - Category:[Nl -
tatu From To Assignment Name Value Enabled Entity Comment Teg
1« I °. sensor_Ports  Location PIN_Y23 Yes
2 I %, sensor_Cinto  Location PIN_Y24 Yes
3 N .- Chave..nicao  Location PIN_AAZ2 Yes
4« [ 24 fsensor_Ginto Location PIN_H15 Yes
5 « I °% Led Porta  Location PIN_G15 Yes
& « I % Led Cinto Location PIN_F15 Yes
7 « [ > Alarme Location PIN_H17 Yes
8 <<new x> <<new>> <<new>>

N
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Programacé&o do PLD

Va em Tools > Programmer > Hardware Setup > USB- Blaster [USB-0]
e add o arquivo. sof
D Programmer - Clee/CrtianolDeap e/ st Cran L el

Fie Edt View Processng Toos Window Hep %) Search altera.com ]

5 Hardnare Setup... | No Hardware Mede: [ITAG ~ Progress:
Enable real-time ISP to allow background programming {for MAX 11 and MAX V' devices)
TR Fike Device Checksum  Usercode  Program/  Verfy  Bank-  Examine
il start Configure Check

e
[ Kockte |
|l save File
[ me
[ Peoom |

A
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Programacé&o do PLD

Apos isso clique em start e acompanhe o progresso

W Programmer - C:/Users/Cristi ste/aulal - aulal - (Chain3.cdf] L. W% o] © s

Fle Edt View Processing Tooks Window Hep % Search altera,com @

2 Hardnare Setp...] No Hardware Mode: [TTAG v) ragress: |

Enable real-time ISP to allow background programming (for MAX IT and MAX V devices)

S T— Fie Device Checksum  Useresde  Program/  Verfy  Bank-  Examne
Configure Chedc
[ dbswp |
3 Auto Detect
X Delete
14 change Fie. o -
el Save File
thu
e

| woton
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Utilizar 2 displays

Utilize agora as mesmas 4 chaves, mas agora para acionar 2
displays. Cuidado, mudar o nome das variaveis de saida. Como
ficaria?

31 kroton
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Bibliografia
desta aula:

-DIT ALTERA DE2-115-
www.altera.com.br

(manual do PLD D2-115)

istemas Digitais: Princi los e
Aplicagoes - TOC
edicao, 2011
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